// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^0-3][0-9]{7}").unwrap();
let string = "91234567
81234567
71234567
61234567
51234567
41234567
31234567
21234567
11234567
01234567";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}