#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\|\s)(((?:\[x]\s[!]?))\K[^[\n]+)"
Local $sString = "- [x] Example task. | Task ends. [x] Another task [x] Another task." & @CRLF & _
"- [x] ! Example task. | This ends. [x] ! Another task." & @CRLF & _
"" & @CRLF & _
"This is a sentence. [x] Task is here." & @CRLF & _
"Other text. Another [x] ! Task is here." & @CRLF & _
"" & @CRLF & _
"Must not match in the table." & @CRLF & _
"| | Task name | Plan | Actual | File |" & @CRLF & _
"| :---- | :-------------| :---------: | :---------: | :------------: |" & @CRLF & _
"| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |" & @CRLF & _
"| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")