import re
regex = re.compile(r"(?<!\|\s)(((?:\[x]\s[!]?))\K[^[\n]+)", flags=re.MULTILINE)
test_str = ("- [x] Example task. | Task ends. [x] Another task [x] Another task.\n"
"- [x] ! Example task. | This ends. [x] ! Another task.\n\n"
"This is a sentence. [x] Task is here.\n"
"Other text. Another [x] ! Task is here.\n\n"
"Must not match in the table.\n"
"| | Task name | Plan | Actual | File |\n"
"| :---- | :-------------| :---------: | :---------: | :------------: |\n"
"| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |\n"
"| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")