re = /(?<!\|\s)(((?:\[x]\s[!]?))\K[^[\n]+)/m
str = '- [x] Example task. | Task ends. [x] Another task [x] Another task.
- [x] ! Example task. | This ends. [x] ! Another task.
This is a sentence. [x] Task is here.
Other text. Another [x] ! Task is here.
Must not match in the table.
| | Task name | Plan | Actual | File |
| :---- | :-------------| :---------: | :---------: | :------------: |
| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |
| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end