import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\|\\s)(((?:\\[x]\\s[!]?))\\K[^[\\n]+)";
final String string = "- [x] Example task. | Task ends. [x] Another task [x] Another task.\n"
+ "- [x] ! Example task. | This ends. [x] ! Another task.\n\n"
+ "This is a sentence. [x] Task is here.\n"
+ "Other text. Another [x] ! Task is here.\n\n"
+ "Must not match in the table.\n"
+ "| | Task name | Plan | Actual | File |\n"
+ "| :---- | :-------------| :---------: | :---------: | :------------: |\n"
+ "| [x] | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |\n"
+ "| [x] ! | Task example. | 08:00-08:45 | 08:00-09:00 | [[task-one]] |\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}