// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*<!\[CDATA\[00000:((?:\s|\S)*?)\]\]>.*").unwrap();
let string = "String srcMsg=\"<?xml version=\\\"1.0\\\" encoding=\\\"UTF-8\\\"?>\\n<root><resultCode>00000</resultCode><resultDesc>
<![CDATA[00000:<ResponseClass Name=\\\"Response\\\">\\n <ResponseSubClass Name=\\\"attributesResponse\\\">\\n
<ITEM>0</ITEM>\\n </ResponseSubClass>\\n</ResponseClass>]]></resultDesc></root>\";
//The right code
java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(\".*<!\\\\[CDATA\\\\[00000:((.|\\n)*)\\\\]\\\\]>.*\");
//wrong code1
//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(\".*<!\\\\[CDATA\\\\[00000:(\\\\s|\\\\S)*\\\\]\\\\]>.*\");
//wrong code2
//java.util.regex.Pattern pP0 = java.util.regex.Pattern.compile(\".*<!\\\\[CDATA\\\\[00000:[\\\\w|\\\\W]*\\\\]\\\\]>.*\");
java
<![CDATA[00000: asdfasdf
sssdgasgf
asfgas
]]>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}