package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`/\*+[^*]*\*+(?:[^/*][^*]*\*+)*/\s*(private\s+final\s+VARIABLE;)`)
var str = `/**
*okay1
*/
menu
/**
* okay2.
*/
private final VARIABLE;`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}