$re = '@/\*+[^*]*\*+(?:[^/*][^*]*\*+)*/\s*(private\s+final\s+VARIABLE;)@';
$str = '/**
*okay1
*/
menu
/**
* okay2.
*/
private final VARIABLE;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);