import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/\\*+[^*]*\\*+(?:[^/*][^*]*\\*+)*/\\s*(private\\s+final\\s+VARIABLE;)";
final String string = "/**\n"
+ "*okay1\n"
+ "*/\n"
+ "menu\n"
+ "/**\n"
+ "* okay2.\n"
+ "*/\n"
+ "private final VARIABLE;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}