re = /\/\*+[^*]*\*+(?:[^\/*][^*]*\*+)*\/\s*(private\s+final\s+VARIABLE;)/
str = '/**
*okay1
*/
menu
/**
* okay2.
*/
private final VARIABLE;'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end