using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d+\b";
string input = @"<p ng-if=""e.element != 'attachment'"" ng-bind-html=""::e.value"" class=""ng-binding ng-scope"">123 Hello a1234 need 123 help with 0365 thanks</p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}