$re = '/\b\d+\b/m';
$str = '<p ng-if="e.element != \'attachment\'" ng-bind-html="::e.value" class="ng-binding ng-scope">123 Hello a1234 need 123 help with 0365 thanks</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);