const regex = /\b\d+\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d+\\b', 'gm')
const str = `<p ng-if="e.element != 'attachment'" ng-bind-html="::e.value" class="ng-binding ng-scope">123 Hello a1234 need 123 help with 0365 thanks</p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}