import re
regex = re.compile(r"\b\d+\b", flags=re.MULTILINE)
test_str = "<p ng-if=\"e.element != 'attachment'\" ng-bind-html=\"::e.value\" class=\"ng-binding ng-scope\">123 Hello a1234 need 123 help with 0365 thanks</p>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")