using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+_pn\b.+$";
string input = @"Adam Nyquist - Never Gonna Stop (Tom Chubb Remix)_pn.mp3
Adam Nyquist - Never Gonna Stop (Tom Chubb Remix)_pblah.mp3";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}