$re = '/^.+_pn\b.+$/m';
$str = 'Adam Nyquist - Never Gonna Stop (Tom Chubb Remix)_pn.mp3
Adam Nyquist - Never Gonna Stop (Tom Chubb Remix)_pblah.mp3';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);