// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.+_pn\b.+$").unwrap();
let string = "Adam Nyquist - Never Gonna Stop (Tom Chubb Remix)_pn.mp3
Adam Nyquist - Never Gonna Stop (Tom Chubb Remix)_pblah.mp3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}