package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b47\b`)
var str = `12;94;128;3;127,147
12;94;128;3;127,47
12;147;128;3;127,47`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}