$re = '/\b47\b/m';
$str = '12;94;128;3;127,147
12;94;128;3;127,47
12;147;128;3;127,47';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);