const regex = /\b47\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b47\\b', 'gm')
const str = `12;94;128;3;127,147
12;94;128;3;127,47
12;147;128;3;127,47`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}