re = /\b47\b/m
str = '12;94;128;3;127,147
12;94;128;3;127,47
12;147;128;3;127,47'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end