#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*are)(?!.*how).*(hello)"
Local $sString = "hello how are you" & @CRLF & _
"how hello are you" & @CRLF & _
"are hello how you" & @CRLF & _
"hello" & @CRLF & _
"are hello" & @CRLF & _
"how hello" & @CRLF & _
"bye hi hello" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")