#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[\/\*A-Z0-9_\s]*(?=\{)\{(CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9])))|NO_SIGNAL).+(?=(CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9])))|NO_SIGNAL)).*$"
Local $sString = "/* UACK */ {CAN_SID_UACK_IDT1S03, CAN_SID_N_UACK_0_IDT1S03}, /* blah blah blah */" & @CRLF & _
"/* UACK */ {NO_SIGNAL, CAN_SID_N_UACK_0_IDT1S03}, /* blah blah blah */" & @CRLF & _
"/* UACK */ {CAN_SID_UACK_IDT1S03, NO_SIGNAL}, /* blah blah blah */" & @CRLF & _
"/* UACK */ {NO_SIGNAL, NO_SIGNAL}, /* blah blah blah */" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")