$re = '/^[\/\*A-Z0-9_\s]*(?=\{)\{(CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9])))|NO_SIGNAL).+(?=(CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9])))|NO_SIGNAL)).*$/m';
$str = '/* UACK */ {CAN_SID_UACK_IDT1S03, CAN_SID_N_UACK_0_IDT1S03}, /* blah blah blah */
/* UACK */ {NO_SIGNAL, CAN_SID_N_UACK_0_IDT1S03}, /* blah blah blah */
/* UACK */ {CAN_SID_UACK_IDT1S03, NO_SIGNAL}, /* blah blah blah */
/* UACK */ {NO_SIGNAL, NO_SIGNAL}, /* blah blah blah */
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);