import Foundation
let pattern = #"^[\/\*A-Z0-9_\s]*(?=\{)\{(CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9])))|NO_SIGNAL).+(?=(CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9])))|NO_SIGNAL)).*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/* UACK */ {CAN_SID_UACK_IDT1S03, CAN_SID_N_UACK_0_IDT1S03}, /* blah blah blah */
/* UACK */ {NO_SIGNAL, CAN_SID_N_UACK_0_IDT1S03}, /* blah blah blah */
/* UACK */ {CAN_SID_UACK_IDT1S03, NO_SIGNAL}, /* blah blah blah */
/* UACK */ {NO_SIGNAL, NO_SIGNAL}, /* blah blah blah */
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)