using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\/\*A-Z0-9_\s]*(?=\{)\{(CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9])))|NO_SIGNAL).+(?=(CAN_SID[A-Z0-9_]+(?=(_([A-Z0-9]{6}[0-9])))|NO_SIGNAL)).*$";
string input = @"/* UACK */ {CAN_SID_UACK_IDT1S03, CAN_SID_N_UACK_0_IDT1S03}, /* blah blah blah */
/* UACK */ {NO_SIGNAL, CAN_SID_N_UACK_0_IDT1S03}, /* blah blah blah */
/* UACK */ {CAN_SID_UACK_IDT1S03, NO_SIGNAL}, /* blah blah blah */
/* UACK */ {NO_SIGNAL, NO_SIGNAL}, /* blah blah blah */
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}