#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\s)([0-9]{4,})(\s?)"
Local $sString = "Terrace 07541207031 RDL 18.02" & @CRLF & _
"Terrace 07541 RDL 18.02" & @CRLF & _
"Terrace 075adf8989 RDL 18.02" & @CRLF & _
"Terrace 075adf898 RDL 18.02" & @CRLF & _
"075898 RDL 18.02" & @CRLF & _
"Terrace RDL 98989"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")