import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\s)([0-9]{4,})(\\s?)";
final String string = "Terrace 07541207031 RDL 18.02\n"
+ "Terrace 07541 RDL 18.02\n"
+ "Terrace 075adf8989 RDL 18.02\n"
+ "Terrace 075adf898 RDL 18.02\n"
+ "075898 RDL 18.02\n"
+ "Terrace RDL 98989";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}