package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\s)([0-9]{4,})(\s?)`)
var str = `Terrace 07541207031 RDL 18.02
Terrace 07541 RDL 18.02
Terrace 075adf8989 RDL 18.02
Terrace 075adf898 RDL 18.02
075898 RDL 18.02
Terrace RDL 98989`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}