re = /(\s)([0-9]{4,})(\s?)/m
str = 'Terrace 07541207031 RDL 18.02
Terrace 07541 RDL 18.02
Terrace 075adf8989 RDL 18.02
Terrace 075adf898 RDL 18.02
075898 RDL 18.02
Terrace RDL 98989'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end