package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\|Name\|(?<name>[^\|]+)\|\s*?\|id\|(?<id>[^\|]+)\|\s*?\|city\|(?<city>[^\|]+)\|`)
var str = `|Name|Vineet|
|id|123|
|city|abc|
|Name|junaid|
|id|987|
|city|lkj|`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}