const regex = /\|Name\|(?<name>[^\|]+)\|\s*?\|id\|(?<id>[^\|]+)\|\s*?\|city\|(?<city>[^\|]+)\|/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\|Name\\|(?<name>[^\\|]+)\\|\\s*?\\|id\\|(?<id>[^\\|]+)\\|\\s*?\\|city\\|(?<city>[^\\|]+)\\|', 'gm')
const str = `|Name|Vineet|
|id|123|
|city|abc|
|Name|junaid|
|id|987|
|city|lkj|`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}