$re = '/\|Name\|(?<name>[^\|]+)\|\s*?\|id\|(?<id>[^\|]+)\|\s*?\|city\|(?<city>[^\|]+)\|/m';
$str = '|Name|Vineet|
|id|123|
|city|abc|
|Name|junaid|
|id|987|
|city|lkj|';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);