re = /\|Name\|(?<name>[^\|]+)\|\s*?\|id\|(?<id>[^\|]+)\|\s*?\|city\|(?<city>[^\|]+)\|/m
str = '|Name|Vineet|
|id|123|
|city|abc|
|Name|junaid|
|id|987|
|city|lkj|'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end