const regex = new RegExp('section\\/([^\\/#]*)', 'gm')
const str = `https://www.test.com/en/section/string-to-get#id=4949
https://www.test.com/en/section/string-to-get/page&2#id=4949`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}