import re
regex = re.compile(r"section\/([^\/#]*)", flags=re.MULTILINE)
test_str = ("https://www.test.com/en/section/string-to-get#id=4949\n"
"https://www.test.com/en/section/string-to-get/page&2#id=4949")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")