#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "( )(\d+)"
Local $sString = "1. Moore, Roger" & @CRLF & _
"2. Connery, Sean" & @CRLF & _
"3. ...." & @CRLF & _
"100. Dalton, Timothy" & @CRLF & _
"110. Bronson, Pierce 111. Gomez, Selena 112. Portman, Nathalie"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")