re = /( )(\d+)/
str = '1. Moore, Roger
2. Connery, Sean
3. ....
100. Dalton, Timothy
110. Bronson, Pierce 111. Gomez, Selena 112. Portman, Nathalie'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end