use strict;
my $str = '1. Moore, Roger
2. Connery, Sean
3. ....
100. Dalton, Timothy
110. Bronson, Pierce 111. Gomez, Selena 112. Portman, Nathalie';
my $regex = qr/( )(\d+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}