using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?:\d+\s*|[a-z0-9]+)-\s*\d+|([-+]?\d+)";
string input = @"From 2020-2022, the frequency of COVID-19 increased when the temperature fell between 10 and -10 degrees. (2) From 2020 - 2022, the frequency of COVID-19 increased when the temperature fell between 10 and -10 degrees. (2)
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}