package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(?:\d+\s*|[a-z0-9]+)-\s*\d+|([-+]?\d+)`)
var str = `From 2020-2022, the frequency of COVID-19 increased when the temperature fell between 10 and -10 degrees. (2) From 2020 - 2022, the frequency of COVID-19 increased when the temperature fell between 10 and -10 degrees. (2)
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}