import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)(?:\\d+\\s*|[a-z0-9]+)-\\s*\\d+|([-+]?\\d+)";
final String string = "From 2020-2022, the frequency of COVID-19 increased when the temperature fell between 10 and -10 degrees. (2) From 2020 - 2022, the frequency of COVID-19 increased when the temperature fell between 10 and -10 degrees. (2)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}