const regex = new RegExp('(?i)(?:\\d+\\s*|[a-z0-9]+)-\\s*\\d+|([-+]?\\d+)', 'gm')
const str = `From 2020-2022, the frequency of COVID-19 increased when the temperature fell between 10 and -10 degrees. (2) From 2020 - 2022, the frequency of COVID-19 increased when the temperature fell between 10 and -10 degrees. (2)
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}