#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(:3:Start)(?:(.*?)(:31:Start.*:31:End))?(.*)(:3:End)"
Local $sString = ":3:Start!@#$%^&*():31:Start!@#$%^&*():31:End!@#$%^&*():3:End" & @CRLF & _
":3:Start!@#$%^&*()!@#$%^&*():3:End"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")