const regex = /(:3:Start)(?:(.*?)(:31:Start.*:31:End))?(.*)(:3:End)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(:3:Start)(?:(.*?)(:31:Start.*:31:End))?(.*)(:3:End)', 'g')
const str = `:3:Start!@#\$%^&*():31:Start!@#\$%^&*():31:End!@#\$%^&*():3:End
:3:Start!@#\$%^&*()!@#\$%^&*():3:End`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}