import Foundation
let pattern = #"(:3:Start)(?:(.*?)(:31:Start.*:31:End))?(.*)(:3:End)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
:3:Start!@#$%^&*():31:Start!@#$%^&*():31:End!@#$%^&*():3:End
:3:Start!@#$%^&*()!@#$%^&*():3:End
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)