package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(:3:Start)(?:(.*?)(:31:Start.*:31:End))?(.*)(:3:End)`)
var str = `:3:Start!@#$%^&*():31:Start!@#$%^&*():31:End!@#$%^&*():3:End
:3:Start!@#$%^&*()!@#$%^&*():3:End`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}