using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:0[1-9]|1[0-2])\/(?:19|[2-9][0-9])$";
string input = @"11/99
13/23
01/19
03/42
03/76
19/14";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}