import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:0[1-9]|1[0-2])\\/(?:19|[2-9][0-9])$";
final String string = "11/99\n"
+ "13/23\n"
+ "01/19\n"
+ "03/42\n"
+ "03/76\n"
+ "19/14";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}