re = /^(?:0[1-9]|1[0-2])\/(?:19|[2-9][0-9])$/m
str = '11/99
13/23
01/19
03/42
03/76
19/14'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end